.NET Framework 3.5 en Windows 8 y posteriores


Algunas aplicaciones requieren tener instalado NET Framework 3.5. En versiones de Windows 7 y anteriores esto no era un problema, se descargaba el paquete y se instalaba, si es que Windows no lo traía ya instalado. Pero en Windows 8 y posteriores está dando problemas.

En Windows 8, 8.1 y 10, por regla general no viene activada dicha carácteristica. Si es así e intentamos activar la característica dará error, y si procedemos a instalar NET Framework 3.5 mediante un paquete descargado desde Microsoft tambíén dará error. Existen múltiples soluciones dadas por el propio Microsoft para este problema pero solo hemos encontrado una solución que funcione.

Hay que tener el DVD de instalación de Windows o en su defecto la imagen (ISO) de dicho DVD. En caso de tener la imagen hay que montarla, para ello basta con darle un doble clic sobre el propio fichero de la imagen.

Una vez localizada la unidad donde está la instalación de Windows ejecutar el Símbolo del sistema (cmd.exe) en modo administrador.

En la ventana que aparece hay que ejecutar la siguiente línea de comandos sustituyendo F: por la unidad donde tenemos la instalación de Windows o la imagen de la misma.

Dism /online /enable-feature /featurename:NetFx3 /All /Source:F:\sources\sxs /LimitAccess
F: es la unidad donde está el dvd o la imagen de Windows 8, 8.1 u 10.

Cuando termine de instalarse, la caracteristica ya estará instalada

Ya se debe poder instalar o ejecutar la aplicación que necesitaba tener activado NET Framework 3.5

 

Etiquetas: net framework, Windows 10, Windows 8
Última actualización:
2017-03-22 12:15
Autor:
Manolo
Revisión:
1.1
Valoración media: 5 (1 voto)

No puedes comentar este registro

Chuck Norris has counted to infinity. Twice.